Categories
Core

New Minimum Requirements in WooCommerce 3.9

When WooCommerce 3.9 is released in January, it will have new required versions of WordPress and PHP. Running WooCommerce 3.9 will require a site running WordPress 5.0 and PHP 7.0 or newer.

We plan to keep developing blocks and other integrations that rely on current versions of WordPress, and this release prepares WooCommerce for these new features so we can deliver the best experience for our users. A very small percentage of WooCommerce stores run versions of WordPress and PHP older than these requirements, so impact will be minimal.

Note that WooCommerce 3.9 includes new “All Products” block (part of WooCommerce Blocks 2.5 release) which requires WordPress 5.3 in order to use it.

What does it mean for your store if your site is affected? Simply put, you will not be able to update to WooCommerce 3.9 when it gets released, so WordPress will not offer you the update. If you’re among these sites, we’ve created document explaining the the benefits of updating to newer versions of WordPress and PHP that includes instructions on how to safely update.

If you have any questions or feedback around the decision and work related to this update, please feel free to leave them in the comments.

By Claudio Sanches

Developer on the WooCommerce team and member of the WordPress Brazilian community.

1 reply on “New Minimum Requirements in WooCommerce 3.9”

Comments are closed.