With the upcoming release of WooCommerce 3.7 we will be updating the minimum required versions of WordPress and PHP. In order to update and run WooCommerce 3.7 you will now be required to have at least WordPress 4.9 and PHP 5.6.

We have to do this to keep up with the code changes within the WordPress ecosystem and to be able to deliver the best experience for our users.

The good news is that according to our research only a very very small percentage of stores are running these outdated versions so the impact will be minimal. What does it mean for your store if affected? Simply put you will not be able to update to WooCommerce 3.7 when it gets released, WordPress will not offer you the update.

We have created a document explaining the details around why updating to newer versions of WordPress and PHP is beneficial and included instructions on how to safely update.

If you have any questions or feedback around the decision and work related to this update, please feel free to leave them in the comments.