Today we had the 28th edition of our Dev Chat, I would like to thank all the people who attended, a total of 14 attendees. If case you missed, you still can read the full backscroll of the dev chat here.

WooCommerce Admin merge being delayed

We’ve learned a lot since we started promoting WooCommerce Admin, today we have more than 200K of active installs, and several feedback from the community to make WooCommerce Admin even better, fixing bugs, improving performance, and more.

Also WooCommerce Admin relies heavily on our Action Scheduler system, it’s used to import historical data, and generate new data while new orders are placed. The Action Scheduler currently have a new version under development that will move from post types to a new custom table, bringing benefits to performance on WooCommerce core and WooCommerce Admin.

So we decided to defer to possibly include in WooCommerce 3.8, and in the meanwhile you’ll are welcomed to try out, and send feedback about your experience.

New package system for feature plugins

Some feature plugins like Blocks, Admin, and REST API (new feature plugin), will be implemented into core as composer dependencies, this will require a build step if you clone WooCommerce from GitHub (development/source version), but it isn’t required if you download from WordPress.org (compiled version).

This will allow everyone to focus in specif features, and also allow the unstop development of many features, not to forget that this allows everyone to test before those features come available on WooCommerce core.

We are using composer to handle those packages, if you like an example of implementation, there’s already a Pull Request under development including the new REST API feature plugin code.

New WordPress & PHP requirements for 3.7

WooCommerce 3.7 will require at least PHP 5.6.20 and WordPress 4.9, to ensure that everyone is prepared, we’ll start including a notice in WooCommerce 3.6.5 talking about those dependencies if you are still running WooCommerce in an outdated PHP or WP version.

As was mentioned earlier in this post, there’s a new version under development of the Action Scheduler, this new version will require PHP 5.6.

Till Next Chat!

Thanks again to all whom attended. If you have any ideas on how to make our chats more helpful, or if you have a question/topic you would like to discuss, please leave a note in the comments below.

The next chat is scheduled for the last Thursday of July – July 25, 2019 at 16:00 UTC.