Categories
Core

June 6th: Dev chat #5

It’s time for our 5th dev chat, if you missed something in the last one, you can recap our summary here.

The next chat will be on June 6th at 16:00 UTC in the #core channel of the WooCommerce Community Slack. If you don’t already have access to the group, you can request an invite at the bottom of the WooCommerce developers page.

Here is the agenda:

If you have anything to propose for the agenda or related to the above, please leave a comment below.

See you there!

5 replies on “June 6th: Dev chat #5”

Now that WooCommerce.com extension licenses will be managed in WooCommerce core from v3.1 onwards, something I’d love to chat about is whether extension compatibility management is slated to be included in core as well (and what that would look like if it is).

The worst issues we’ve seen store owners having with 3.0 the last couple of months stem from updating WooCommerce before updating Subscriptions or other extensions. If core included some extension compatibility handling with basic version dependency management, it could help a lot of store owners avoid those types of issues with WC 4.0 and beyond.

Liked by 4 people

That sounds like a great suggestion. It’s a pity that it wouldn’t solve incompatibility checks with extensions that are sold on other marketplaces than WooCommerce.com.

Like

Notes from dev chat on this topic: https://woocommerce.wordpress.com/2017/06/07/dev-chat-summary-june-6th/

– Sites had a high amount of errors when people upgraded to WooCommerce 3.0 and were using extensions that were not ready for WooCommerce 3.0.
– We need to show warnings or programmatically manage extensions that are not compatible with new versions of WooCommerce somehow.
– An issue has been created on GitHub for this. Please leave feedback or ideas.

Like

Comments are closed.